The fix has now been deployed across all environments. We will continue to monitor the situation to ensure everything remains stable.
Posted Mar 26, 2026 - 10:41 CET
Identified
We’ve found the problem and fixed it. The update is now being rolled out.
Posted Mar 26, 2026 - 10:04 CET
Investigating
Some customers are currently experiencing issues with executing data imports from the Norce Commerce Admin UI. We're currently investigating the issue and will update the status page at 10:15 or earlier.
Posted Mar 26, 2026 - 09:38 CET
This incident affected: Norce Commerce (Norce Commerce).