The issue has been resolved and all systems are operational.
Posted Feb 25, 2026 - 13:25 CET
Update
We are investigating intermittent delays occurring for some customers. Our team is actively looking into the issue and will provide updates as soon as more information is available.
Posted Feb 25, 2026 - 09:34 CET
Investigating
Our team is working to find the root cause. This issue may affect usage for customers in all regions. We will share more information in our next update.
Posted Feb 25, 2026 - 09:33 CET
Monitoring
We have applied a fix for the performance issue affecting some customers in various regions. We will closely monitor the service to ensure stability and provide further updates as needed.
Posted Feb 24, 2026 - 12:42 CET
Identified
Some customers may experience intermittent delays. We are focused on restoring normal performance and will provide updates as they become available. Next steps include continuous monitoring and implementation of the fix.
Posted Feb 24, 2026 - 12:02 CET
Update
We have received reports that the administrator interface is slow or unresponsive for some admin users. Our teams are investigating the cause to restore normal operations. Affected customers may experience prolonged loading or timeouts. We will share more details as soon as possible.
Posted Feb 24, 2026 - 11:38 CET
Investigating
We have received reports that the administrator interface is slow or unresponsive for some admin users. Our teams are investigating the cause to restore normal operations. Affected customers may experience prolonged loading or timeouts. We will share more details as soon as possible.
Posted Feb 24, 2026 - 11:37 CET
This incident affected: Norce Commerce (Norce Commerce).