Performance issues

Incident Report for Norce

Resolved

Customers may have experienced disruptions in some regions, but all regions are now fully operational. We will continue to monitor closely to maintain stability. If you experience any further issues, please contact support for assistance.
Posted Oct 24, 2025 - 08:01 CEST

Monitoring

Some customers in multiple regions experienced slower response times. We have fixed the core problem and will watch performance closely to ensure the service remains stable. We will share any additional information as soon as possible.
Posted Oct 23, 2025 - 15:18 CEST

Identified

Our team is working to restore normal performance for customers experiencing slower response times. This issue appears to affect customers in multiple regions. We will provide more information as soon as it is available.
Posted Oct 23, 2025 - 15:10 CEST
This incident affected: Norce Commerce (Norce Commerce).