Admin Stage and Prod

Incident Report for Norce

Resolved

System performance has remained stable, and full functionality has been restored across all regions.
We’ll continue to monitor closely, but this incident is now considered resolved.
Posted Jun 10, 2026 - 16:09 CEST

Monitoring

System performance has improved, and full functionality has been restored for all regions. We’ll continue to monitor performance to ensure it remains stable and to quickly address any issues that arise.
Posted Jun 10, 2026 - 12:29 CEST

Investigating

We’re currently investigating reports that the admin stage and production services are unresponsive. Some customers may be experiencing difficulties logging in and completing tasks. Our teams are working to restore performance as quickly as possible, and we will share more information once available.
Posted Jun 10, 2026 - 11:39 CEST
This incident affected: Norce Commerce (Norce Commerce, Stage).