As of 14:42 UTC, Cloudflare reports that they have resolved the issue and are continuing to monitor the situation. We will close this incident as Resolved on our side but may re-open it if Cloudflare changes their status from Resolved to Ongoing.
Posted Nov 18, 2025 - 15:54 CET
Monitoring
A global CDN disruption at Cloudflare is causing delays in delivering some images and media. Our team is actively monitoring and working with the provider to reduce impact. We will share more information as soon as it becomes available.
More information about the current status of Cloudflare's ongoing effort to resolve the issue can be found at https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 13:55 CET
This incident affected: Norce Commerce (Norce Commerce).