The previously reported timeout issues affecting GetCustomer requests have now been resolved. As part of our mitigation efforts, we scaled up our Redis instances to improve caching efficiency and reduce database load. Additionally, we have made improvements and optimizations to StormAPI to enhance overall system performance and stability.
Following these adjustments, system performance has stabilized, and we are no longer observing timeout-related disruptions.
We sincerely appreciate the patience and understanding of our customers and partners while we worked to resolve this issue. Our teams will continue to monitor system performance to ensure continued stability.
Thank you for your support.
Posted Mar 06, 2025 - 10:44 CET
Update
We are continuing to investigate an issue where some requests to our service are experiencing timeouts. Our analysis indicates that the majority of these timeouts are related to CustomerService, specifically during GetCustomer requests.
We have identified that these requests generate a high number of sequential SQL queries. While each individual query executes quickly, the cumulative execution time exceeds the allowed threshold, causing timeouts on the requesting side.
As part of our ongoing mitigation efforts, we have scaled up our Redis instances to improve caching efficiency and reduce the load on our database. Our engineering teams are actively monitoring the situation and working on further optimizations.
We will provide additional updates as soon as more information becomes available.
Thank you for your patience.
Posted Mar 05, 2025 - 14:52 CET
Identified
We are currently investigating an issue where some requests to our service are experiencing timeouts. Our analysis indicates that the majority of these timeouts are related to CustomerService, specifically during GetCustomer requests.
We have identified that these requests are generating a high number of sequential SQL queries. While each individual query executes quickly, the cumulative execution time exceeds the allowed threshold, causing timeouts on the requesting side.
Our engineering teams are actively working on a resolution, and we will provide updates as soon as more information becomes available.
Thank you for your patience.
Posted Mar 05, 2025 - 12:25 CET
This incident affected: Norce Commerce (Norce Commerce).